Contents
2. VLAN Creation and Configuration in web GUI 2
2.3 Assigning Ports to new VLAN (Access Ports) 3
3. VLAN Creation and Configuration in CLI 3
4. Configuring Ports as Trunk or Hybrid Ports 6
4.1 Trunk Port And Hybrid Port 6
4.2 Trunk Port and Hybrid Port Configuration using Web 6
4.3 Trunk Port and Hybrid Port Configuration using CLI 7
VLAN or Virtual LAN is a sub network which separates an existing physical network into multiple logical networks. Thus, each VLAN creates its own broadcast domain. They work as though they are created using independent switches.
They allow network administrators to automatically limit access to specified groups of users by dividing them into different isolated LAN segments.
Navigate to the VLAN tab -> VLAN Configuration, Enter a VLAN ID and click ‘Apply’ and a VLAN with ID 2 will be created.
Navigate to the Layer 3 tab -> IP Basic -> VLAN Interface, enter VLAN ID as ‘2’ and click ‘Apply’ then select ‘2’ from the table. Enter the IP address and the subnet beside IP Address/Subnet prefix. Click the ‘Apply’ icon. Here, the VLAN 2 is configured with IP address 192.168.2.1/24.
Navigate to the VLAN tab -> Access Port, select an interface to assign as an access port to the new VLAN, and choose ‘2’ as the VLAN and click ‘Apply’. Here we have configured port 9 as an access port to VLAN2.
Now we have a new VLAN with ID 2, IP address 192.168.2.1/24 and one access port, that is, interface ge1/9. To view and save the configuration, navigate to the ‘Tools’ tab.
Similarly, other ports can be configured as access ports.
Login to the console or shell of the switch. The default credentials are Username: admin & Password: admin.
Run the following commands:
Switch>enable
Getting into configuration mode
Switch#configure terminal
Entering VLAN configuration mode to create a new VLAN
Switch(config)#vlan database
Creating and enabling a new VLAN ‘vlan 3’
Switch(config-vlan)#vlan 3
Switch(config-vlan)#exit
Switch(config)#ip interface vlan 3
Entering interface configuration mode
Switch(config)#interface ge1/13
Configuring interface ge1/13 as access port for vlan 3
Switch(config-ge1/13)#switchport access vlan 3
Switch(config-ge1/13)#exit
Entering vlan3 configuration mode
Switch(config)#interface vlan3
Configuring IP address for vlan3
Switch(config-vlan3)#ip address 192.168.3.1/24
Switch(config-vlan3)#exit
Switch(config)#exit
Saving the configuration
Switch#write
To configure multiple ports in one go, enter;
Switch(config)#interface ge1/11 ge1/16
Switch(config-ge1/11-16)#switchport access vlan 3
Switch(config-ge1/11-16)#exit
Switch(config)#exit
Switch#write
The following two commands will show a brief information about the various interfaces and VLANS, wherein there will be information about the newly created VLANs as well. An example is shown in the following image which contains the configuration done above.
Switch#show ip interface brief
Switch#show vlan
A trunk port is a specific type of port on a network switch that allows data to flow across a network node for multiple virtual local area networks or VLANs. In simple words if a port is configured as a trunk port, it will allow traffic from all tagged VLANs (as configured) on the switch.
A Hybrid port is a combination of Access and trunk port. It is a port connected to either switches or hosts. It can receive both tagged and untagged frames and assigns untagged frames a default configured VLAN (Port VLAN ID). It receives tagged frames with VLANs of which the port is a member.
After logging into the web GUI, navigate to VLAN tab -> Trunk Port, choose a port to be configured as a trunk port, select a VLAN to be its Default VLAN, select the tagged VLANs as per your choice and click ‘Apply’ as shown below. Do a similar configuration on another switch and connect both of them through the trunk ports. Here we are configuring port ge1/23 as the trunk port.
For Hybrid port configuration, navigate to VLAN tab -> Hybrid Port. Its configuration is similar, and here you can choose which VLANs to be default, tagged or untagged as shown below. Here we are configuring port ge1/24 as the hybrid port.
After logging into the console or shell, follow the given commands:
Switch>enable
Switch#configure terminal
Note: There are various options when it comes to hybrid or trunk configuration
1. Trunk port configuration:
# Configuring interface ge1/21 as trunk port
Switch(config)#interface ge1/21
Switch(config-ge1/21)#switchport mode trunk
# To configure a particular VLAN as tagged member
Switch(config-ge1/21)#switchport trunk allowed vlan add <VLAN ID or list>
# To configure all VLANs as tagged, VLAN1 excluded
Switch(config-ge1/21)#switchport trunk allowed vlan all
# To remove all VLANs from membership of the trunk port
Switch(config-ge1/21)#switchport trunk allowed vlan none
# To remove a particular VLAN from membership of the trunk port
Switch(config-ge1/21)#switchport trunk allowed vlan remove <VLAN ID or list>
# To change the native VLAN of the port
Switch(config-ge1/21)#switchport trunk native vlan <VLAN ID>
2. Hybrid port configuration:
# Configuring interface ge1/22 as hybrid port
Switch(config)#interface ge1/22
Switch(config-ge1/22)#switchport mode hybrid
# To configure a particular VLAN as tagged member
Switch(config-ge1/22)#switchport trunk allowed vlan add <VLAN ID or list> egress-tagged enable
# To configure a particular VLAN as untagged member
Switch(config-ge/22)#switchport trunk allowed vlan add <VLAN ID or list> egress-tagged disable
# To configure all VLANs as tagged, VLAN1 excluded
Switch(config-ge1/22)#switchport hybrid allowed vlan all
# To remove all VLANs from membership of the hybrid port. Implementing this command will revert back the native VLAN of the port to 1
Switch(config-ge1/22)#switchport hybrid allowed vlan none
# To remove a particular VLAN from membership of the hybrid port
Switch(config-ge1/22)#switchport hybrid allowed vlan remove <VLAN ID or list>
# To change the native VLAN of the port
Switch(config-ge1/22)#switchport hybrid native vlan <VLAN ID>
Note: There are only two ways of writing ‘VLAN ID or list’. You can either specify a list like ‘2-4’ or can specify individual VLANs by separating them using commas like 1,2,3,5. You can’t give a group of VLAN lists like ‘2-4, 6-9’.